Zephir on Windows and linux - errors

Hi Guys !

Afters hours and hours spend on trying to install zephir on my windows 8, i finally managed to build an single .zep file !

Now, i've copied the .dll from /ext/Release directory, into my xampp/php/ext and added the extension=<filename>.dll in my php.ini - I'm using latest xampp with php 5.5.24 - and when I restart my Apache, the httpd.exe throws an error "The program can't start because php5.dll is missing form your computer". I'm really baffled by this eror, searching on net for the last hours and I can't find an answer !

Does anyone had this issue before ?

Problem 2) I've install vagrant and followed the tutorial from blog, and managed to install everything.Then I went to /vagrant directory as it is shared between the host and the guest, used zaphir init <andmynamespace>, all the files were generated, then copied my .zep file from my windows host into the right directory and runned zephir build. Again all went fine, the .so file was created but as my main development platform is on windows, i wanted to use the files from <namespace>/etc/ to build the .dll extension for my xampp installation - to be honest i didn't tried to use the .so extension and test if the extension works on linux - .

Now, using the Developer Command Promt for Visual Studio 2012, i tried to run command "cl <namespace>.c" inside the /ext/ directory that was build by zaphir on linux, but an fatal error its appearing in my developer command promt "Fatal error C1083: Cannot open include file: php.h: No such file or directory"

The greatest way for me would be to compile the extension for both windows, my dev. pc but for linux also !

Could please someone help me with this issues ? Give me some guidance as I have to admit, I don't have alot of knowledge about developing/compiling in C !

Thank you

To the windows part: Be careful, apache mostly uses a thread safe (TS) version of PHP, but the windows guide focuses on creating binaries for non thread safe (recommended, NTS) versions of PHP.

So you have to be careful and insteadof using NTS downloads use TS downloads (mostly PHP and PHP DevPack Downloads)

That may already be the solution to your problem.