Error when i try use extension in centos 7

when I try to compile the extension in Centos 7 with php 5.6.13, I get this error Unable ti load dynamic library ´/usr/lib64/php/modules/extension.so´ - ´/usr/lib64/php/modules/extension.so´: undefine symbol: phpjsondecode_ex in Unknown on line 0

I use Zpehir 0.9.1.a-dev version

I have also just made a post 'json_decode causes failures.'. I have exactly the same issue. I will keep a check on this post for replies, I suggest that you do the same for my post.

If I find a solution I will post it to you here. Jonathan.

I have finally found a solution to the jsondecode issue. Being new to linux I am not sure if it is the correct solution: JSON support was shown as being available via phpinfo(), the json extension is loaded via json.ini within the php.d directory. I commented out the extension in /etc/php.d/json.ini and added 'extension=json.so' to /etc/php.ini BEFORE any other extension. This seems to have solved the jsondecode errors that I was receiving. I have further tests to do to make sure json_decode is working properly, but at least I have some progress.

Initial tests show that this solution works