Zephir\Exception: Extension namespace cannot be loaded :: New install :: newbie going slowly mad

2016 Oct. 4 zephir version 0.9.4a-dev-22f6632128

OS: Mac OS X 10.9.5

PHP etc: PHP 7.0.11 (cli) (built: Sep 16 2016 22:16:18) ( NTS ) Copyright (c) 1997-2016 The PHP Group Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies

Compiler GCC: gcc -v Configured with: --prefix=/Applications/Xcode.app/Contents/Developer/usr --with-gxx-include-dir=/usr/include/c++/4.2.1 Apple LLVM version 5.1 (clang-503.0.40) (based on LLVM 3.4svn) Target: x86_64-apple-darwin13.4.0 Thread model: posix

OK, I have a fresh install of zephir. Cloned and did the recomended ./install from that dir. Install appears to have worked. zephir help displays the expected response. Followed instructions at https://docs.zephir-lang.com/en/latest/tutorial.html

zephir build from BLAH/utils/utils gets Zephir\Exception: Extension namespace cannot be loaded

zephir build greeting.zep from higher level dirs gets Zephir\Exception: Extension namespace cannot be loaded

I tried with another similar test called, unoriginally, test/test/test.zep Same result.

I am going slowly mad trying to troubleshoot this. I hadn't thought I had done enough yet to mess up someething so basic. But here I am.

I would be much obliged if someone could point me to some instructions or things I should look into.

Thanks for reading.

To build a PHP extension and use Zephir you need the following requirements:

  • gcc >= 4.x/clang >= 3.x
  • re2c 0.13 or later
  • gnu make 3.81 or later
  • autoconf 2.31 or later
  • automake 1.14 or later
  • libpcre3
  • php development headers and tools

For more refer to the documentation page: https://docs.zephir-lang.com/en/latest/install.html#prerequisites