Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

The Zephir Parser extension is not loaded.

For a new zephir , I installed a new ubuntu 16.04 and follow this page (https://docs.zephir-lang.com/en/latest/install.html) to setup.

When I try to build , the error message is

[email protected]:~/zephir/utils$ zephir build
 [Zephir\Exception\IllegalStateException]:

────────────────────────────────────────────────────────────
  The Zephir Parser extension is not loaded.
  Note: Zephir no longer distributed with internal parser.

  To install latest stable Zephir Parser please refer to:
  https://github.com/phalcon/php-zephir-parser
────────────────────────────────────────────────────────────

at Library/Compiler.php(209)

Stack trace:
#0 Library/Compiler.php(260): Zephir\Compiler->preCompile('utils/greeting....')
#1 Library/Compiler.php(790): Zephir\Compiler->recursivePreCompile('utils')
#2 Library/Compiler.php(1025): Zephir\Compiler->generate(Object(Zephir\Commands\CommandBuild))
#3 Library/Compiler.php(1163): Zephir\Compiler->compile(Object(Zephir\Commands\CommandBuild), false)
#4 Library/Compiler.php(1260): Zephir\Compiler->install(Object(Zephir\Commands\CommandBuild), false)
#5 Library/Commands/CommandAbstract.php(144): Zephir\Compiler->build(Object(Zephir\Commands\CommandBuild))
#6 Library/Bootstrap.php(114): Zephir\Commands\CommandAbstract->execute(Object(Zephir\Config), Object(Zephir\Logger))
#7 compiler.php(17): Zephir\Bootstrap->boot()
#8 {main}

what I install in ubuntu

gcc: 4:5.3.1-1ubuntu1

re2c: 0.16-1

make: 4.1-6

autoconf: 2.69-9

automake: 1:1.15-4ubuntu1

libpcre3: 2:8.38-3.1

php: 7.0.4-7buntu2

How do I solve this problem ?



162
Accepted
answer

You need Zephir Parser compiled and loaded in php : https://github.com/phalcon/php-zephir-parser Read requirement : https://github.com/phalcon/zephir